<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" >
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">

	<link rel="profile" href="https://gmpg.org/xfn/11">

	<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css">
	<link rel="stylesheet" href="https://cdn.jsdelivr.net/bxslider/4.2.12/jquery.bxslider.css">

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-53524189-3"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-53524189-3');
</script>




	<meta name="theme-color" content="#16a2ea">

<script>var clicky_site_ids = clicky_site_ids || []; clicky_site_ids.push(101243450);</script>
<script async src="//static.getclicky.com/js"></script>

<script data-ad-client="ca-pub-6749561928889346" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
	<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>
  window.googletag = window.googletag || {cmd: []};
  googletag.cmd.push(function() {
    var REFRESH_KEY = 'refresh';
    var REFRESH_VALUE = 'true';   
    //desktop ROS 
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_1', [300, 250], 'div-gpt-ad-1570802487184-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_2', [300, 250], 'div-gpt-ad-1570821891441-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_3', [300, 250], 'div-gpt-ad-1570821979731-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_4', [300, 250], 'div-gpt-ad-1570823235622-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_300x250_5', [300, 250], 'div-gpt-ad-1570823235622-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_1', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_2', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_leader_3', [[970, 250], [970, 90], [728, 90]], 'div-gpt-ad-1570823321511-2').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_tower_1', [[300, 600], [300, 250]], 'div-gpt-ad-1571013535193-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_desktop_ros_tower_2', [[300, 600], [300, 250]], 'div-gpt-ad-1571013535193-1').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    
    googletag.defineSlot('/1048906/metro_philly_ros_pixel_1x1', [1, 1], 'div-gpt-ad-1570992069741-0').addService(googletag.pubads());
    
    //mobile ROS
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_1', [300, 250], 'div-gpt-ad-1571013590977-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_2', [300, 250], 'div-gpt-ad-1571013590977-2').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_3', [300, 250], 'div-gpt-ad-1571013590977-3').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_4', [300, 250], 'div-gpt-ad-1571013590977-4').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_ros_300x250_5', [300, 250], 'div-gpt-ad-1571013590977-5').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
    googletag.defineSlot('/1048906/metro_philly_mobile_leader', [320, 50], 'div-gpt-ad-1571013707377-0').setTargeting(REFRESH_KEY, REFRESH_VALUE).addService(googletag.pubads());
  
    //keyword targeting
    googletag.pubads().setTargeting("SCKeyword", ["sports"] );

    //Refresh Check 
    var SECONDS_TO_WAIT_AFTER_VIEWABILITY = 60;
     googletag.pubads().addEventListener('impressionViewable', function(event) {
     var slot = event.slot;
     if (slot.getTargeting(REFRESH_KEY).indexOf(REFRESH_VALUE) > -1) {
     setTimeout(function() {
        googletag.pubads().refresh([slot]);
       //console.log("fresh ads");
       }, SECONDS_TO_WAIT_AFTER_VIEWABILITY * 1000);
     }
    });

    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-6749561928889346",
          enable_page_level_ads: true
     });
</script>
 

	<title>Man found beaten, slashed and tied to bed in Philly - Metro Philadelphia</title>

<!-- This site is optimized with the Yoast SEO plugin v12.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Man found beaten, slashed and tied to bed in Philly - Metro Philadelphia" />
<meta property="og:description" content="The body of a 59-year-old man was found beaten, slashed and tied to a bed in a Northeast Philly home, police said. Investigators discovered the body on Tuesday, just before 3 a.m., in the 8400 block of Algon Avenue in the Rhawnhurst neighborhood. Cops were called to the home after a report of a man &hellip;" />
<meta property="og:url" content="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/" />
<meta property="og:site_name" content="Metro Philadelphia" />
<meta property="article:tag" content="Philly" />
<meta property="article:section" content="Sports" />
<meta property="article:published_time" content="2019-11-05T16:09:00-05:00" />
<meta property="article:modified_time" content="2020-02-05T23:40:31-05:00" />
<meta property="og:updated_time" content="2020-02-05T23:40:31-05:00" />
<meta property="og:image" content="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg" />
<meta property="og:image:secure_url" content="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg" />
<meta property="og:image:width" content="875" />
<meta property="og:image:height" content="493" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The body of a 59-year-old man was found beaten, slashed and tied to a bed in a Northeast Philly home, police said. Investigators discovered the body on Tuesday, just before 3 a.m., in the 8400 block of Algon Avenue in the Rhawnhurst neighborhood. Cops were called to the home after a report of a man [&hellip;]" />
<meta name="twitter:title" content="Man found beaten, slashed and tied to bed in Philly - Metro Philadelphia" />
<meta name="twitter:image" content="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://philly.metro.us/#website","url":"https://philly.metro.us/","name":"Metro Philadelphia","potentialAction":{"@type":"SearchAction","target":"https://philly.metro.us/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/#primaryimage","url":"https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg","width":875,"height":493,"caption":"crime tape"},{"@type":"WebPage","@id":"https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/#webpage","url":"https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/","inLanguage":"en-US","name":"Man found beaten, slashed and tied to bed in Philly - Metro Philadelphia","isPartOf":{"@id":"https://philly.metro.us/#website"},"primaryImageOfPage":{"@id":"https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/#primaryimage"},"datePublished":"2019-11-05T16:09:00-05:00","dateModified":"2020-02-05T23:40:31-05:00","author":{"@id":"https://philly.metro.us/#/schema/person/3be8694f36cdd3e8adeb238b8398e900"}},{"@type":["Person"],"@id":"https://philly.metro.us/#/schema/person/3be8694f36cdd3e8adeb238b8398e900","name":"Metro Philadelphia","image":{"@type":"ImageObject","@id":"https://philly.metro.us/#authorlogo","url":"https://philly.metro.us/wp-content/uploads/2020/01/metro-logo-square-192x192.png","caption":"Metro Philadelphia"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/philly.metro.us\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tribe-accessibility-css-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/common/src/resources/css/accessibility.min.css?ver=4.9.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-full-calendar-style-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-custom-jquery-styles-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/vendor/jquery/smoothness/jquery-ui-1.8.23.custom.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-bootstrap-datepicker-css-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/css/bootstrap-datepicker.standalone.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-skeleton.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-mobile-style-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme-mobile.min.css?ver=4.9.9' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='schneps-magma-admin-styles-css'  href='https://philly.metro.us/wp-content/plugins/schneps-magma-calendar-extensions/css/schneps-magma-calendar-extensions.css?ver=1.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-reset-style-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/common/src/resources/css/reset.min.css?ver=4.9.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-common-style-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/common/src/resources/css/common.min.css?ver=4.9.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css-css'  href='https://philly.metro.us/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.9.18' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://philly.metro.us/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='main_stylesheet-css'  href='https://philly.metro.us/wp-content/plugins/spotim-comments/assets/stylesheets/main.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://philly.metro.us/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='theme-css-css'  href='https://philly.metro.us/wp-content/themes/schnepstheme/build/main.b4604c1bea2bac35c7dc.css' type='text/css' media='all' />
<link rel='stylesheet' id='child-theme-css-css'  href='https://philly.metro.us/wp-content/themes/schnepstheme-philly/build/main.3d49a905bec8603afa7d.css' type='text/css' media='all' />
<script type='text/javascript' src='https://philly.metro.us/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://philly.metro.us/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=5.4.1#pubid=wp-f5ecca744013cbc75a73ab967a93c239'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pp_vars = {"publisher_id":"76dd5de7-67e8-44ed-a248-ec77daf8930e","widget_endpoint":"https:\/\/widget.pico.tools","plugin_version":"0.8.1","widget_version":"744863bf0c1f9eb12996f9a258569211","post_id":"528","post_type":"post","post_title":"Man found beaten, slashed and tied to bed in Philly","taxonomies_for_this_post_type":["category","post_tag","post_format","flags","post_status","ef_editorial_meta","following_users","ef_usergroup","author"],"list_of_taxonomies":["category","post_tag","nav_menu","link_category","post_format","flags","tribe_events_cat","post_status","ef_editorial_meta","following_users","ef_usergroup","author"],"show_read_more_button":"1","taxonomies":{"category":["sports"],"post_tag":["philly"]},"resource_ref":"name=man-found-beaten-slashed-and-tied-to-bed-in-philly"};
/* ]]> */
</script>
<script type='text/javascript' src='https://philly.metro.us/wp-content/plugins/pico/includes/js/read-more.js?ver=744863bf0c1f9eb12996f9a258569211'></script>
<link rel='https://api.w.org/' href='https://philly.metro.us/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://philly.metro.us/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphilly.metro.us%2Fman-found-beaten-slashed-and-tied-to-bed-in-philly%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://philly.metro.us/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphilly.metro.us%2Fman-found-beaten-slashed-and-tied-to-bed-in-philly%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://philly.metro.us"><link rel="https://theeventscalendar.com/" href="https://philly.metro.us/wp-json/tribe/events/v1/" /><link rel="preconnect" href="https://fonts.googleapis.com/" crossorigin>
<link rel="dns-prefetch" href="https://fonts.googleapis.com/">
<link rel="preconnect" href="https://cdnjs.cloudflare.com/" crossorigin>
<link rel="dns-prefetch" href="https://cdnjs.cloudflare.com/">
<link rel="shortcut icon" href="https://philly.metro.us/wp-content/uploads/2020/01/metro-logo-icon.png"><link rel="apple-touch-icon-precomposed" href="https://philly.metro.us/wp-content/uploads/2020/01/metro-logo-square.png"><script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.8"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "5.4.1"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":300}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = []; } else {  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.8","plugin_mode":"WordPress","anonymous_profile_id":"wp-f5ecca744013cbc75a73ab967a93c239","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script></head>




<body class="post-template-default single single-post postid-528 single-format-standard tribe-no-js tribe-theme-parent-schnepstheme tribe-theme-child-schnepstheme-philly singular man-found-beaten-slashed-and-tied-to-bed-in-philly">
	<div id="grid-wrapper">
	<div class="ad-container header-ad-container">
<!-- /1048906/metro_philly_desktop_ros_leader_1 -->
<div id='div-gpt-ad-1570823321511-0'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823321511-0'); });
  </script>
</div>
</div>
<div class="potential-overlay-container">	
<div class="potential-overlay">
	<div class="header-wrapper">
<header class="header-logonav_samerow site-masthead"> 

	<div class="logo-container">
		<a href="/"><img src="https://philly.metro.us/wp-content/uploads/2020/01/metro-logo-black.png" alt="Metro Philadelphia" class="fullLogo"><img src="https://philly.metro.us/wp-content/uploads/2020/01/metro-logo-black.png" alt="" class="scrolldownLogo"></a>   
	</div>

	<div class="nav-container">
	
	<!-- Navigation - Singlerow -->
<!-- loop through menu row -->

<nav class="main-nav" role="navigation">
	<ul class="nav-menu-items">
	
				
		<li class="nav-menu-item nav-sections nav-menu-item-with-submenu menu-opener menu-only">
			  <a class="nav-menu-link" href="/">Sections</a>
			  				  <ul class="dropdown">
				  					  <li><a href="/category/news/">News</a></li>
				  					  <li><a href="/category/sports/">Sports</a></li>
				  					  <li><a href="/category/entertainment/">Entertainment</a></li>
				  					  <li><a href="/category/things-to-do/">Things to Do</a></li>
				  					  <li><a href="/category/lifestyle/">Lifestyle</a></li>
				  					  <li><a href="/category/crime/">Crime</a></li>
				              
				  </ul>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-digital-editions nav-6">
			  <a class="nav-menu-link" href="http://philadelphia.metro.us" target="_blank">Digital Editions</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-podcasts nav-5">
			  <a class="nav-menu-link" href="https://podcasts.schnepsmedia.com" target="_blank">Podcasts</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-jobs nav-4">
			  <a class="nav-menu-link" href="https://www.dreamjobsnyc.com/" target="_blank">Jobs</a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-metrobet nav-3 nav-menu-item-image">
			  <a class="nav-menu-link" href="https://www.metro.us/sports/bet" target="_blank"><img src="https://philly.metro.us/wp-content/uploads/2020/01/metrobettingicon.svg" alt="MetroBet"></a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-metroplay nav-2 nav-menu-item-image">
			  <a class="nav-menu-link" href="https://www.metro.us/play" target="_blank"><img src="https://philly.metro.us/wp-content/uploads/2020/01/metro_play.svg" alt="MetroPlay"></a>
			                  
		  </li>
	  			
		<li class="nav-menu-item nav-games nav-1">
			  <a class="nav-menu-link" href="https://games.metro.us/" target="_blank">Games</a>
			                  
		  </li>
	  
		<li class="nav-menu-item-basic nav-menu-more nav-menu-item-with-submenu menu-opener menu-only">
			<a class="nav-menu-link">More</a>
			<ul class="dropdown">
												
				<li class="nav-sections"><a href="/">Sections</a></li>
												
				<li class="nav-digital-editions more-subnav-6"><a href="http://philadelphia.metro.us" target="_blank">Digital Editions</a></li>
												
				<li class="nav-podcasts more-subnav-5"><a href="https://podcasts.schnepsmedia.com" target="_blank">Podcasts</a></li>
												
				<li class="nav-jobs more-subnav-4"><a href="https://www.dreamjobsnyc.com/" target="_blank">Jobs</a></li>
												
				<li class="nav-metrobet more-subnav-3"><a href="https://www.metro.us/sports/bet" target="_blank">MetroBet</a></li>
												
				<li class="nav-metroplay more-subnav-2"><a href="https://www.metro.us/play" target="_blank">MetroPlay</a></li>
												
				<li class="nav-games more-subnav-1"><a href="https://games.metro.us/" target="_blank">Games</a></li>
				            
			</ul>
		</li>

		<li class="nav-menu-social-links social-links nav-menu-icon-row">				
		<a href="https://www.facebook.com/MetroPhilly/" target="_blank"><i class="fa fa-facebook" aria-hidden="true" aria-label="Facebook"></i></a>
			
				
		<a href="https://twitter.com/MetroPhilly" target="_blank"><i class="fa fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
			
				
		<a href="https://www.instagram.com/metrophilly" target="_blank"><i class="fa fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
			
				
</li>
		<li class="nav-menu-search-newsletter nav-menu-icon-row"><a class="nav-menu-newsletter" href="/newsletter/"><i class="fa fa-envelope" aria-hidden="true" aria-label="Sign up for our email newsletter"></i></a>

<a class="nav-menu-search" href="/?s="><i class="fa fa-search" aria-hidden="true" aria-label="Search"></i></a>

</li>

		<li class="nav-menu-search-box bkg-main">
<form role="search" method="get" class="search-form" action="/">
<label>
	<span class="screen-reader-text">Search for:</span>
	<input type="search" class="search-field" placeholder="Search" value="" name="s">
</label>
<button type="submit" class="search-submit icon-search-basic" value="Search"><i class="fa fa-search" aria-hidden="true" aria-label="Search"></i></button>
</form>		</li>

    </ul>
</nav>

        <div class="hamburger">
<i class="fa fa-bars opener" aria-hidden="true"></i>
<i class="fa fa-times closer" aria-hidden="true"></i>
    </div>    
    </div>
    
</header>
</div>


 
</div>
</div>
<div class="content-container single-template transparent-container wallpaper-container">
<div class="container-center-cut">
	 

    <div class="content-section standard-singlepost">

        <div class="content-main">
                
            <article id="post-528" class="post-528 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-philly">
                <div class="article-header">
                    
                                        			<div class="category-box category-label category-label-sports">
			<a href="https://philly.metro.us/category/sports/">Sports</a>
			</div>
		                    
                    <h1 class="article-title">Man found beaten, slashed and tied to bed in Philly</h1>                        <div class="article-meta">
                            <span class="posted-on">Posted on <a href="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/" rel="bookmark"><time class="entry-date published updated" datetime="2019-11-05T11:09:00-05:00">November 5, 2019</time></a></span>                                                        <span class="byline"> <img src="https://philly.metro.us/wp-content/uploads/2020/01/metro-logo-square-192x192.png" width="32" height="32" alt="Avatar" class="avatar avatar-32wp-user-avatar wp-user-avatar-32 alignnone photo avatar-default" />Becca  Glasser-baker</span>                        </div><!-- .article-meta -->
                                        </div><!-- .article-header -->

                <div class="post-thumbnail" style="max-width: 875px;">
	<div class="image-wrapper">
				<img width="875" height="493" src="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg" class="crop-center wp-post-image" alt="crime tape" srcset="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg 875w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-700x394.jpg 700w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-768x433.jpg 768w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-384x216.jpg 384w" sizes="(max-width: 875px) 100vw, 875px" />			</div>
	<div class="image-caption">Accident or crime scene cordon tape, police line do not cross. It is nighttime, emergency lights of police cars flashing blue, red and white in the background</div>	<div class="image-credit">iStock</div></div><!-- .post-thumbnail -->
                <div class="article-content">
                    <div class="at-above-post addthis_tool" data-url="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/"></div><div id="pico"><p>The body of a 59-year-old man was found beaten, slashed and tied to a bed in a Northeast Philly home, police said.</p>
<p>Investigators discovered the body on Tuesday, just before 3 a.m., in the 8400 block of Algon Avenue in the Rhawnhurst neighborhood. Cops were called to the home after a report of a man in distress. </p>
<p>In a statement, police said they found the victim, whose identity was not released, “partially tied to the bed with a massive head wound and several slashes to his chest.”</p>
<p>Outlets report that the man was pronounced dead at the scene. </p>
<p>No arrests have been made, but a woman was reportedly seen leaving the home before police arrived.</p>
</div><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/"></div><!-- AddThis Share Buttons generic via filter on the_content -->
                    
                </div><!-- .article-content -->

                <div class="article-footer">
                    <div class="share-post-container">
    <h4>Share Post:</h4>
	<div class="share-post">
		<div class="addthis_toolbox addthis_default_style">
			<a class="addthis_button_facebook"></a>
			<a class="addthis_button_twitter"></a>
			<a class="addthis_button_pinterest_share"></a>
			<a class="addthis_button_email"></a>
		</div>
	</div>
</div>
                    
                    <div class="author-meta">
                        	<h3 class="about-the-author">About the Author</h3>
 
                    </div>

											<div class="comments-container">
													</div>
					
                </div><!-- .article-footer-->
            </article> 
		        </div>
		<div class="sidebar-section widget-area">
            <section class="widget_promo widget standard"><div class="subscribe-now-box bkg-pale promo-content">
<h2 class="section-title text-color-plain"><i class="fa fa-newspaper-o" aria-hidden="true"></i>Today’s Paper</h2>
<p class="todays-papers">
<a href="http://philadelphia.metro.us" class="newspaper-cover"><img src="https://edition.pagesuite-professional.co.uk/get_image.aspx?W=240&amp;pbid=1c9b73c7-ef5b-4623-8125-49e2bf5f9ccd&amp;rand=2020051723"></a></p>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_1 -->
<div id='div-gpt-ad-1570802487184-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570802487184-0'); });
  </script>
</div>
</div>
</section>
<section class="widget_promo widget priority"><div class="community-partner-box bkg-secd promo-content">
<h2 class="section-title text-color-white"><a href="/community-partner/"><i class="fa fa-handshake-o text-color-accent" aria-hidden="true"></i>Partner with us to support local news</a></h2>
<p><a href="/community-partner/" class="basic-button bkg-tert text-color-white">Learn More</a></p>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_2 -->
<div id='div-gpt-ad-1570821891441-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570821891441-0'); });
  </script>
</div>
</div>
</section><section class="widget_promo widget optional"><div class="top-posts news">
<h2 class="widget-title">News</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/every-other-week-recycling-schedule-extended/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/GettyImages-483507551-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/every-other-week-recycling-schedule-extended/">Every-other-week recycling schedule extended</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/breaking-through-covid-19/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/Breakthrough1-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" srcset="https://philly.metro.us/wp-content/uploads/2020/05/Breakthrough1-192x192.jpg 192w, https://philly.metro.us/wp-content/uploads/2020/05/Breakthrough1-700x700.jpg 700w, https://philly.metro.us/wp-content/uploads/2020/05/Breakthrough1-768x768.jpg 768w, https://philly.metro.us/wp-content/uploads/2020/05/Breakthrough1-384x384.jpg 384w, https://philly.metro.us/wp-content/uploads/2020/05/Breakthrough1-900x900.jpg 900w, https://philly.metro.us/wp-content/uploads/2020/05/Breakthrough1.jpg 1080w" sizes="(max-width: 192px) 100vw, 192px" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/breaking-through-covid-19/">Breaking through COVID-19</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/voter-registration-deadline-is-monday/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/GettyImages-523277961-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/voter-registration-deadline-is-monday/">Voter registration deadline is Monday</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/south-philly-barbacoas-kitchens-are-open-to-feed-those-in-need/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/DSC06201-2-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/south-philly-barbacoas-kitchens-are-open-to-feed-those-in-need/">South Philly Barbacoa&#8217;s kitchens are open to feed those in need</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/mural-arts-project-commemorates-heroes-from-the-pandemic/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/Remembering-a-Forgotten-Hero-Catto_SWeinik-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/mural-arts-project-commemorates-heroes-from-the-pandemic/">Mural Arts project commemorates heroes from the pandemic</a></span></li></ul>
</div></section><section class="widget_box widget">
<div class="ad-container card-ad-container">
<!-- /1048906/metro_philly_desktop_ros_300x250_3 -->
<div id='div-gpt-ad-1570821979731-0' style='width: 300px; height: 250px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570821979731-0'); });
  </script>
</div>
</div>
</section><section class="widget_promo widget optional"><div class="top-posts arts">
<h2 class="widget-title">Entertainment</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/mural-arts-project-commemorates-heroes-from-the-pandemic/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/Remembering-a-Forgotten-Hero-Catto_SWeinik-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/mural-arts-project-commemorates-heroes-from-the-pandemic/">Mural Arts project commemorates heroes from the pandemic</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/support-the-philadelphia-zoo-in-style/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/IMG_8234-1-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/support-the-philadelphia-zoo-in-style/">Support the Philadelphia Zoo in style</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/fun-things-to-safely-do-this-weekend-in-philly-5/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/IMG_1652-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/fun-things-to-safely-do-this-weekend-in-philly-5/">Fun things to safely do this weekend in Philly</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/join-work-and-rachel-bambrick-this-month-to-support-a-great-cause/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/RAH-WORK-Family-and-RAH-Team-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/join-work-and-rachel-bambrick-this-month-to-support-a-great-cause/">Join WORK and Rachel Bambrick this month to support a great cause</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/the-thrilling-chase-of-blood-and-money/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/Untitled_1.34.2-e1589221621541-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/the-thrilling-chase-of-blood-and-money/">The thrilling chase of &#8216;Blood and Money&#8217;</a></span></li></ul>
</div></section><section class="widget_promo widget optional"><div class="top-posts sports">
<h2 class="widget-title">Sports</h2>
<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/mlb-clubs-to-take-sizable-financial-hit-in-2020-season-with-no-fans/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/bryce_harper-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/mlb-clubs-to-take-sizable-financial-hit-in-2020-season-with-no-fans/">MLB clubs to take sizable financial hit in 2020 season with no fans</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/nhl-could-jump-into-24-team-playoffs-upon-2020-return/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/stanley_cup_ice-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/nhl-could-jump-into-24-team-playoffs-upon-2020-return/">NHL could jump into 24-team playoffs upon 2020 return</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/mlb-submits-strict-67-page-health-safety-guidelines-for-return/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/04/sptn_generic_baseball_0422-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/mlb-submits-strict-67-page-health-safety-guidelines-for-return/">MLB submits strict 67-page health, safety guidelines for return</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/nascar-bundesliga-headline-sports-return-this-weekend/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/lewandowski-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/nascar-bundesliga-headline-sports-return-this-weekend/">NASCAR, Bundesliga headline sports&#8217; return this weekend</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/time-for-mlb-to-make-universal-dh-permanent-pantorno/"><img width="192" height="192" src="https://philly.metro.us/wp-content/uploads/2020/05/sptp_hoskins_0515-192x192.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/time-for-mlb-to-make-universal-dh-permanent-pantorno/">Time for MLB to make universal DH permanent: Pantorno</a></span></li></ul>
</div></section>        </div>
    </div><!-- #main -->

	 
</div>
</div><!-- #primary -->

<div class="ad-container content-ad-container">
<!-- /1048906/metro_philly_desktop_ros_leader_2 -->
<div id='div-gpt-ad-1570823321511-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570823321511-1'); });
  </script>
</div>
</div> 

<div id="comments-anchor" class="spot-im-comments comments-area">
        <script async
            data-spotim-module="spotim-launcher"
            data-article-tags="Philly"
            src="https://launcher.spot.im/spot/sp_37Vm0WQ5"
            data-social-reviews="false"
            data-post-id="528"
            data-post-url="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/"
            data-short-url="https://philly.metro.us/?p=528"
            data-messages-count="10"
            data-wp-import-endpoint="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/feed/spotim/"
            data-facebook-url="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/"
            data-disqus-shortname=""
            data-disqus-url="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/"
            data-disqus-identifier="528 https://philly.metro.us/?p=528"
            data-community-question=""
            data-seo-enabled="false"
            data-wp-v="p-4.5.2/wp-5.4.1"
    ></script>
    </div>

<div class="related-posts-footer">
<h2 class="related-title">Related Articles</h2>
	<ul class="display-posts-listing"><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/septas-santa-express-ushers-in-the-holiday-season/"><img width="700" height="545" src="https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-700x545.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-700x545.jpg 700w, https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-1200x933.jpg 1200w, https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-768x597.jpg 768w, https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-1536x1195.jpg 1536w, https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-2048x1593.jpg 2048w, https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-384x299.jpg 384w, https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-900x700.jpg 900w, https://philly.metro.us/wp-content/uploads/2019/11/santa-express-septa-4-1600x1245.jpg 1600w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/septas-santa-express-ushers-in-the-holiday-season/">SEPTA&#8217;s Santa Express ushers in the holiday season</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/500-philly-teachers-talk-to-nbc-about-all-things-education/"><img width="700" height="435" src="https://philly.metro.us/wp-content/uploads/2020/02/classroom-700x435.jpg" class="attachment-medium size-medium wp-post-image" alt="" srcset="https://philly.metro.us/wp-content/uploads/2020/02/classroom-700x435.jpg 700w, https://philly.metro.us/wp-content/uploads/2020/02/classroom-384x239.jpg 384w, https://philly.metro.us/wp-content/uploads/2020/02/classroom.jpg 750w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/500-philly-teachers-talk-to-nbc-about-all-things-education/">500 Philly teachers talk to NBC about all things education</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/suv-car-collides-with-school-bus-in-west-philly/"><img width="700" height="394" src="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-700x394.jpg" class="attachment-medium size-medium wp-post-image" alt="crime tape" srcset="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-700x394.jpg 700w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-768x433.jpg 768w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-384x216.jpg 384w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg 875w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/suv-car-collides-with-school-bus-in-west-philly/">SUV, car collides with school bus in West Philly</a></span></li><li class="listing-item article-container cards-design"><a class="image" href="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/"><img width="700" height="394" src="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-700x394.jpg" class="attachment-medium size-medium wp-post-image" alt="crime tape" srcset="https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-700x394.jpg 700w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-768x433.jpg 768w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875-384x216.jpg 384w, https://philly.metro.us/wp-content/uploads/2020/02/crime_tape_875.jpg 875w" sizes="(max-width: 700px) 100vw, 700px" /></a> <span class="title-wrapper"><a class="title" href="https://philly.metro.us/man-found-beaten-slashed-and-tied-to-bed-in-philly/">Man found beaten, slashed and tied to bed in Philly</a></span></li></ul></div> 

<div class="hero-container sister-sites-container component-container card" style="background: #e7f1ec">

	<div class="component-title-section">
		<h2 class="section-title">More from our Sister Sites</h2>
	</div>

    <div class="hero-section sister-sites component-content-section hero-blocks-4">
    				<article class="article-container cards-design">
					<a href="https://www.caribbeanlifenews.com/jeffrey-dujon-forget-cricket-this-year/"><img src="https://www.caribbeanlifenews.com/wp-content/uploads/2020/05/jeffery-dujon-cricket-2020-05-15-azad-cl01-479x700.jpg" alt=""></a>					<div class="context-box">
				<div class="blurb category-label site-label-caribbean-life"><a href="https://caribbeanlifenews.com">Caribbean Life</a></div>
				<h2><a href="https://www.caribbeanlifenews.com/jeffrey-dujon-forget-cricket-this-year/">Jeffrey Dujon: Forget cricket this year</a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://www.amny.com/editorial/queens-man-killed-after-flames-rip-through-upper-floors-of-his-home/"><img src="https://www.amny.com/wp-content/uploads/2020/05/Todd04242018278789-300x200.jpg" alt=""></a>					<div class="context-box">
				<div class="blurb category-label site-label-amny"><a href="https://www.amny.com">AMNY</a></div>
				<h2><a href="https://www.amny.com/editorial/queens-man-killed-after-flames-rip-through-upper-floors-of-his-home/">Queens man killed after flames rip through upper floors of his home</a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://podcasts.schnepsmedia.com/2020/05/15/amrush-weekend-edition-a-home-bartending-lesson-with-carly-cerasuolo/"><img src="https://podcasts.schnepsmedia.com/wp-content/uploads/2020/04/am-rush-800x800.png" alt=""></a>					<div class="context-box">
				<div class="blurb category-label site-label-schneps-podcasts"><a href="https://podcasts.schnepsmedia.com">Schneps Podcasts</a></div>
				<h2><a href="https://podcasts.schnepsmedia.com/2020/05/15/amrush-weekend-edition-a-home-bartending-lesson-with-carly-cerasuolo/">amRUSH Weekend Edition: A home bartending lesson with Carly Cerasuolo</a></h2>
					</div>
				</article>
								<article class="article-container cards-design">
					<a href="https://www.gaycitynews.com/franklin-grahams-send-off-cleaning-up-after-a-false-samaritan/"><img src="https://www.gaycitynews.com/wp-content/uploads/2020/05/Samaritans-Curse-Reverend-Billy-700x467.jpg" alt=""></a>					<div class="context-box">
				<div class="blurb category-label site-label-gay-city-news"><a href="https://www.gaycitynews.com">Gay City News</a></div>
				<h2><a href="https://www.gaycitynews.com/franklin-grahams-send-off-cleaning-up-after-a-false-samaritan/">Franklin Graham&#8217;s Send-Off: Cleaning Up After a False Samaritan</a></h2>
					</div>
				</article>
				    </div>
</div>
<div class="subscribe-section-container component-container">
	<div class="component-container-center-cut">
	<div class="subscribe-section component-content-section">

<h2 class="section-title"><a href="/newsletter/">Get the Ultimate Philly Newsletter</a></h2>

<p>Sign up for our daily news explosion.</p>

<!-- Begin Mailchimp Signup Form -->
<div id="mc_embed_signup">
<form action="https://brooklynpaper.us7.list-manage.com/subscribe/post?u=1b2948b7c6ab19db3239219c9&amp;id=d524e77f6a" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>

    <div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>

    <div id="mc_embed_signup_scroll">    
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL" placeholder="Enter Email">

	<input type="text" value="" name="MMERGE11" class="" id="mce-MMERGE11" placeholder="Zip">
	    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_1b2948b7c6ab19db3239219c9_173f3d1250" tabindex="-1" value=""></div>
    <input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button basic-button bkg-secd">
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[11]='MMERGE11';ftypes[11]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup-->

	</div>
	</div>
</div>




    <footer class="site-footer">

        	<nav class="footer-nav-menu"><ul>
							<li>
			<a class="" href="/newsletter/" target="">
			<span>Newsletter</span>
			</a>
		</li>
							<li>
			<a class="" href="http://philadelphia.metro.us" target="_blank">
			<span>Digital Editions</span>
			</a>
		</li>
							<li>
			<a class="" href="/contact-us/" target="">
			<span>Contact Us</span>
			</a>
		</li>
							<li>
			<a class="" href="https://www.schnepsevents.com/ " target="">
			<span>Networking Events</span>
			</a>
		</li>
		
	
			<li class="nav-menu-social-links social-links nav-menu-icon-row">				
		<a href="https://www.facebook.com/MetroPhilly/" target="_blank"><i class="fa fa-facebook" aria-hidden="true" aria-label="Facebook"></i></a>
			
				
		<a href="https://twitter.com/MetroPhilly" target="_blank"><i class="fa fa-twitter" aria-hidden="true" aria-label="Twitter"></i></a>
			
				
		<a href="https://www.instagram.com/metrophilly" target="_blank"><i class="fa fa-instagram" aria-hidden="true" aria-label="Instagram"></i></a>
			
				
</li>
		
	</ul></nav>
 

        	<nav class="site-info"><ul>
													<li class="copyright">
			<a href="https://www.schnepsmedia.com/" target="_blank">
			<span>© 2020 Schneps Media</span>
			</a>
		</li>
													<li class="">
			<a href="/privacy-policy/" target="">
			<span>Privacy Policy</span>
			</a>
		</li>
													<li class="">
			<a href="/terms/" target="">
			<span>Terms of Use</span>
			</a>
		</li>
		</ul></nav>
 

    </footer>
	
</div> <!--#grid-wrappr-->	

<nav id="theStickyNavBar" class="sticky sticky-fa sticky-bottom-bar" role="navigation">
	<ul>
													<li>
					<a href="/search/" target="" title="">
					<i class="fa fa-search" aria-hidden="true"></i>					Search					</a>
				</li>
											<li>
					<a href="http://philadelphia.metro.us" target="" title="">
					<i class="fa fa-newspaper-o" aria-hidden="true"></i>					Editions					</a>
				</li>
											<li>
					<a href="http://podcasts.schnepsmedia.com" target="" title="">
					<i class="fa fa-headphones" aria-hidden="true"></i>					Podcasts					</a>
				</li>
											<li>
					<a href="/newsletter/" target="" title="">
					<i class="fa fa-envelope" aria-hidden="true"></i>					Sign Up					</a>
				</li>
						</ul>        
</nav> 

    <script>
        var unruly = window.unruly || {};
        unruly.native = unruly.native || {};
        unruly.native.siteId = 1156604;
    </script>
    <script src="//video.unrulymedia.com/native/native-loader.js"></script>



		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><div id='pico-widget-container'></div><script type='text/javascript' src='https://philly.metro.us/wp-content/plugins/the-events-calendar/common/src/resources/js/tribe-common.min.js?ver=4.9.18'></script>
<script type='text/javascript' src='https://philly.metro.us/wp-content/plugins/the-events-calendar/common/src/resources/js/tooltip.min.js?ver=4.9.18'></script>
<script type='text/javascript' src='https://philly.metro.us/wp-content/themes/schnepstheme/build/bundle.97f1c696.js'></script>
<script type='text/javascript' src='https://philly.metro.us/wp-content/themes/schnepstheme-philly/build/bundle.7f03455f.js'></script>
<script type='text/javascript' src='https://philly.metro.us/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>

<!-- /1048906/metro_philly_ros_pixel_1x1 -->
<div id='div-gpt-ad-1570992069741-0' style='width: 1px; height: 1px;'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-1570992069741-0'); });
  </script>
</div>
 





</body>
</html>
